windows cannot automatically bind the ip protocol to the ip stack

windows cannot automatically bind the ip protocol to the ip stack

Uugh!

I’ve just spent 2 hours tracking this down.

My wife is running Windows 7 Home on a Compaq Presario and her wireless networking stopped.

When I ran the diagnostic, the only meaningful message I could get was:

windows cannot automatically bind the ip protocol to the ip stack

Not very helpful!

Googling provided many similar articles.

This didn’t help, but I did notice that “Kaspersky Anti-Virus” seemed to be the cause.

This was odd (the laptop has AVG). But I did notice something… AVG was constantly giving me a reminder that it had been updated and needed a reboot. After the 3rd reboot, I thought this was it.

So I tried to uninstall AVG, but got the message “AVG Error Code 0xC0070643”.

Some more googling suggested I restart in Safe Mode and manually delete the c:\program files\avg folders.

This seemed a little drastic, but I had nothing else to go by so I deleted the folders.

After a reboot, still no networking!

At this point, I think that AVG is the cause and that during the automatic upgrade, it didn’t uninstall the previous version. Not much help and still no networking. I also must add that the ethernet port didn’t work either.

Again this got me thinking that AVG might have some sort of intercept to networking level? A quick check under Control Panel / Network and Intenet / Network Connections, select the wireless network card, right click on Properties and what did I see?

Ugg! 2nd from the top, AVG network filter driver.

Disabled this and I was good to go!

I downloaded AVG and installed. AVG thought it was already installed, so I selected Repair and good to go.

Again it was odd, but AVG seemed to hang. It has been running for the last 20 minutes “repairing”. The progress bar is changing (so it hasn’t stopped). It just seems to be going very very slowly.

I hope this helps!

Rock on,
Christian